Synchronizing Database Version with SharePoint Version

SharePoint Error: “The template you have chosen is invalid or cannot be found”

Received the following error when trying to make use of a newly installed template in the creation of a new sub-site: "The template you have chosen is invalid or cannot be found".

This is apparently attributed to a blip in the upgrade process whereby the Sharepoint Server receives an upgrade that trickles down to individual sites (SP2), but for whatever reason the corresponding database for some sites do not get upgraded.

This problem was fixed by making use of an undocumented option of the stssadm tool to force an upgrade of the particular database associated with the problem site. The syntax is as follows and must be run from the command line with a path to the stsadm.exe.

stsadm –o upgrade –url -forceupgrade

This forces the Site Database to upgrade the schema to the same version as the front-end web server.

IIS is restarted automatically as part of this “command”.

Add Feedback